Vagrant - Install composer 1.x instead off composer 2.x
- Composer 2.x is not compatible with the dependencies described in the composer.json file.
- But, the default composer installer installs the latest version 2.x.
- we need to download Composer 1.x via the following URL:
- php -r "readfile('https://getcomposer.org/installer');" | sudo php -- --install-dir=/usr/local/bin --filename=composer + cd /usr/local/bin + wget --no-verbose https://getcomposer.org/composer-1.phar + mv composer-1.phar composer + chmod +x composer
phpro/grumphp is used to check commits. Version grumphp 0.15.2 is the latest version compatible with php 7.0, but is not compatible with composer v2.
Your requirements could not be resolved to an installable set of packages. Problem 1 - Root composer.json requires phpro/grumphp ^0.15.2 -> satisfiable by phpro/grumphp[v0.15.2]. - phpro/grumphp v0.15.2 requires composer-plugin-api ~1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint. You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.