Commit f2f1f019 authored by Fabien Combernous's avatar Fabien Combernous

Merge branch '44-check-stdlib-requirement' into 'master'

Resolve "check stdlib requirement"

Closes #44

See merge request !50
parents 1e461145 f373abf7
# Freeipa Puppet module
#### Table of Contents
1. [Description](#description)
......@@ -24,18 +23,19 @@ The module should not affect a previous installation of FreeIPA, it should fail
Below are all items that module can affect:
- Modifiy /etc/hosts
- Modify /etc/resolv.conf
- Install the following packages if not present: autofs, bind-dyndb-ldap, epel-release, sssd-common, sssdtools, ipa-client, ipa-server, ipa-server-dns, kstart, openldap-clients
* Modifiy /etc/hosts (if `$freeipa::manage_host_entry` true)
* Install the following packages if not present: autofs, bind-dyndb-ldap, epel-release, sssd-common, sssdtools, ipa-client, ipa-server, ipa-server-dns, kstart, openldap-clients
Installation of Freeipa server will obviously install a ntp server, a DNS server, a LDAP Directory, a Kerberos server, apache, Certmonger and PKI Tomcat.
### Setup Requirements
This module requires [puppetlabs/stdlib](https://forge.puppetlabs.com/puppetlabs/stdlib) >= 4.13.0.
This module requires :
* puppetlabs-stdlib
* stahnma-epel
## Usage
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment