Commit 74fc6b5e authored by Fabien Combernous's avatar Fabien Combernous

clean up Gemfile for unused versions

parent d9f1e6cb
Pipeline #4262 canceled with stages
in 1 minute and 34 seconds
......@@ -27,18 +27,3 @@ Gemfile:
- gem: 'puppet-lint'
- gem: 'rspec'
- gem: 'rake'
- gem: 'beaker-vagrant'
version: '0.5.0'
- gem: 'net-telnet'
gem: 'net-telnet'
condition: "Gem::Version.new(RUBY_VERSION.dup) == Gem::Version.new('2.1.9')"
version: '< 0.2.0'
- gem: 'rubocop'
condition: "Gem::Version.new(RUBY_VERSION.dup) == Gem::Version.new('2.1.9')"
version: '< 0.58.0'
- gem: 'net-telnet'
condition: "Gem::Version.new(RUBY_VERSION.dup) == Gem::Version.new('2.4.4')"
version: '>= 0.2.0'
- gem: 'rubocop'
condition: "Gem::Version.new(RUBY_VERSION.dup) == Gem::Version.new('2.4.4')"
version: '>= 0.58.0'
......@@ -41,11 +41,6 @@ group :development do
gem "puppet-lint", require: false
gem "rspec", require: false
gem "rake", require: false
gem "beaker-vagrant", '0.5.0', require: false
gem "net-telnet", '< 0.2.0', require: false if Gem::Version.new(RUBY_VERSION.dup) == Gem::Version.new('2.1.9')
gem "rubocop", '< 0.58.0', require: false if Gem::Version.new(RUBY_VERSION.dup) == Gem::Version.new('2.1.9')
gem "net-telnet", '>= 0.2.0', require: false if Gem::Version.new(RUBY_VERSION.dup) == Gem::Version.new('2.4.4')
gem "rubocop", '>= 0.58.0', require: false if Gem::Version.new(RUBY_VERSION.dup) == Gem::Version.new('2.4.4')
end
puppet_version = ENV['PUPPET_GEM_VERSION']
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment