Commit d7be45fc authored by THEO GUILLON's avatar THEO GUILLON
Browse files

Merge branch '364-corrections-suite-a-l-utilisation-de-postgresql-12-2-ubuntu-20-04' into '1.2.0'

Resolve "Corrections suite à l'utilisation de PostgreSQL 12.2 (Ubuntu 20.04)"

See merge request libriciel/pole-citoyens/web-DPO/web-DPO!328
parents 62380a78 aa7aa1d7
......@@ -63,7 +63,8 @@ services:
environment:
- TZ=${TZ}
- PGTZ=${TZ}
image: postgres:10.9
- POSTGRES_HOST_AUTH_METHOD=trust
image: postgres:12.2
ports:
- "2032:5432"
volumes:
......
......@@ -46,6 +46,7 @@ RUN ( \
libssl-dev=1.1.* \
locales=2.31-* \
netbase=6.1 \
pdftk=2.02-* \
php-imagick=3.4.* \
php-pear=1:1.10.* \
php-xdebug=2.9.* \
......@@ -79,17 +80,13 @@ RUN ( \
&& pear channel-update pear.php.net \
&& pear install XML_RPC2-1.1.4 \
&& pip3 install -Iv esprima==4.0.1 pgsanity==0.2.9 \
&& ( set +e ; add-apt-repository ppa:malteworld/ppa ; echo hack-404 > /dev/null ) \
&& ( set +e ; apt-get update ; echo hack-404 > /dev/null ) \
# @info: On installe node etc dans un second temps, sinon ça pose problème avec php7.4-dev
# @info: On installe pdftk également dans un second temps car on a besoin du paquet build-essential pour add-apt-repository
&& apt-get install \
--assume-yes \
--no-install-recommends \
--show-upgraded \
node-gyp=6.1.* \
npm=6.14.* \
pdftk=2.02-* \
&& apt-get clean \
&& rm -rf /var/lib/apt/lists/* \
)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment