Commit b9a1a282 authored by Fabrice Gangler's avatar Fabrice Gangler 🎨
Browse files

FIX(composer.json): constrain the php version (>=7.0.0 <7.1)

Refs: #753
parent 027364b1
Pipeline #7691 passed with stage
in 2 minutes and 17 seconds
# On 2019-05-03
# On 2019-05-03
Necessary for unit tests:
Necessary for unit tests:
- "josegonzalez/cakephp-upload": "~3.4"
- "cakephp/migrations": "~1.6"
......@@ -17,9 +17,12 @@ Necessary for using helper (view)
Needed to keep PHP version <7.1 (i.e. being OK with PHP 7.0.33)
```
# prod
"doctrine/annotations": "1.4.*",
"doctrine/instantiator": "1.0.5",
"myclabs/deep-copy": "1.7.0",
# dev
"symfony/browser-kit": "3.4.29",
"symfony/css-selector": "3.4.29",
"symfony/debug": "3.4.29",
......@@ -28,5 +31,5 @@ Needed to keep PHP version <7.1 (i.e. being OK with PHP 7.0.33)
"symfony/filesystem": "3.4.29",
"symfony/finder": "3.4.29",
"symfony/process": "3.4.29",
"symfony/var-dumper": "3.4.29"
"symfony/var-dumper": "3.4.29"
```
......@@ -5,7 +5,8 @@
"type": "project",
"license": "AGPL-3.0-or-later",
"require": {
"php": ">=5.4.16",
"php": ">=7.0.0 <7.1",
"admad/cakephp-jwt-auth": "~2.0",
"alt3/cakephp-swagger": "1.0.*",
"bcrowe/cakephp-api-pagination": "~1.0",
......
......@@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies",
"This file is @generated automatically"
],
"content-hash": "aaa058afd128a37301a0807836aadd4f",
"content-hash": "aac4e673af581586706dc84baa85544a",
"packages": [
{
"name": "admad/cakephp-jwt-auth",
......@@ -5077,7 +5077,7 @@
"prefer-stable": true,
"prefer-lowest": false,
"platform": {
"php": ">=5.4.16"
"php": ">=7.0.0 <7.1"
},
"platform-dev": {
"ext-json": "*"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment